A Crafts Community For Craft Ideas & DIY Projects - Craftster.org
Help | About | Contact | Press | Advertise | Cookie Policy | Terms | Site Map
Welcome, Guest.
Please login or register.
Random Tip: Fanatic Friends of Craftster now have the ability to disable ads on Craftster! Read more here.
Total Members: 313,986
Currently Running With Scissors:
404 Guests and 12 Users
Home Craftster Community Crafting Articles Craft Tutorials My Craftster Crafting Calendar City Guides Craft Shop

Pages: [1]
Jump to page:
  Show Images Only     Send this topic  |  Print  |  Bookmark  
Topic: Bobbin Troubles, Please Help  (Read 533 times)
Tags for this thread:  Add new tag
Share the love... Pin it Submit to reddit
« on: September 25, 2007 07:49:07 PM »

I just got a new old sewing machine from my aunt.  I'd ask her to help solve this, but I think she used the thing twice in it's life and she's probably had it for at least 15 years.

Anyway, I hope I can describe this in a way that makes sense.  When I'm sewing the material will get suddenly caught up and stop completely.  It seems like it's because something is catching the thread on the bobbin so that fifteen or twenty strands are trying to be pulled through at once.  Since it's wrapped around the bobbin they obviously can't all go at once, it's the same strand, so it just stops completely.  I then have to open the bobbin door and cut it out.

I checked the manual again to make sure I had the bobbin in the right way and it was, tried sewing again and the same thing happened.  I tried turning it just in case and the same thing happened.  I can get it to sew about six inches and then it chews up the bobbin thread so that I have to cut it out.. and it happens in a second, so I think it's happening all at once.

Please help, thank you in advance,
« Reply #1 on: September 26, 2007 11:38:50 AM »

Ok, that used to happen to me when i got my sewin machine, but i adjusted the tension on the machine, you should really try to ask your aunt for this. It's really hard to find whats wrong  with your machine, at least for me it was, you have to explore your machine, really explore it, that did it for me.

« Reply #2 on: September 26, 2007 03:02:26 PM »

My mom came over today and brought some different bobbins.  That has seemed to fix the problem... at least for now.

Thanks, though. :-D
Threads you might like:
Pages: [1] Jump to page:
  Send this topic  |  Print  |  Bookmark  
Jump to:  

only results with images
include swap threads
advanced search

Latest Blog Articles
Tute Tuesday: Apple Cozy
What The World Needs Now...
Meatless Monday: German Pancake

Support Craftster
Become a
Friend of Craftster

Buy Craftster Swag
Buy Craft Supplies

Craftster heartily thanks the following peeps...

Follow Craftster...

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC
SimplePortal 2.3.5 © 2008-2012, SimplePortal
Valid XHTML 1.0! Valid CSS!

Copyright ©2003-2017, Craftster.org an Internet Brands company.