A Crafts Community For Craft Ideas & DIY Projects - Craftster.org
Help | About | Contact | Press | Advertise | Terms | Site Map
Welcome, Guest.
Please login or register.
Random Tip: Joining an Organized Swap? Please review the rules and info on a regular basis.
Total Members: 299,182
Currently Running With Scissors:
634 Guests and 21 Users
Home Craftster Community Crafting Articles Craft Tutorials My Craftster Crafting Calendar City Guides Craft Shop


Pages: [1]
Jump to page:
  Show Images Only     Send this topic  |  Print  |  Bookmark  
Topic: Help!! Viking Topaz 20 Issues  (Read 1094 times)
Tags for this thread:  Add new tag
Share the love... Pin it Submit to reddit add to Wists
1+
 
Serephita
« on: November 03, 2012 04:32:59 PM »

I am currently the owner of a Viking Designer Topaz 20, and have had my machine for almost a year. I have been fortunate enough to not have many issues with it until a couple of days ago, when I received a commission for some patches. Upon plugging the design into my software, I didn't think much of it - the number of stitches and the difficulty of the design itself were nothing unusual for what I do. Unfortunately though when I went to actually embroider, my machine began to nest underneath, and I actually at one point had to cut away the fabric and thread and use a pair of tweezers to get the nesting out from around the bobbin! Since then, I have changed the thread color and brand, the needle, the amount of stabilizer (less, more, etc), the fabric and wound a brand new bobbin to try and fix the problem (I made sure that the thread on the bobbin is wound correctly, as well). Since I changed the bobbin, the issue seems to be with the top thread tension - and since its automatically set by the machine, there isn't really anything I can do to change it - since it will tell me after anywhere from 5-100 stitches that the top thread is broken, when its not, nor is it stripping. Soon after this is when it will start to nest.

I've also tried other designs that my machine has never had problems with before, but now is! I have a link to an image of the most recent projects and designs that are giving me trouble (the holes are from where I had to physically cut the project out of the machine because of the nesting):

http://i45.tinypic.com/se9iyt.jpg

Has anyone run into this issue before/know how to fix it? Right now the patches I make are my only source of income so I'm hesitant to have the machine shipped out for repairs.
THIS ROCKS   Logged
kaz814
Cooking Moderator
Purses, Bags, Wallets Moderator
Reusing, Recycling, Recrafting Moderator

Tutorial Contributor

Friend of Craftster Friend of Craftster

Offline Offline

Posts: 5733
Joined: 03-Oct-2009


View Profile WWW
« Reply #1 on: November 04, 2012 05:49:51 AM »

Hi Serephita!  First of all, welcome to Craftster. Smiley

I have the Viking Topaz 20, too, and had those same issues!  I bought mine about a year ago - are you sure we aren't the same person?

Anyway, I took mine to the Joann's Viking shop and of course, it worked perfectly while I was there.  Is the thread coming off the Thread Take Up?  That was my problem, and Cindy at the store said that would cause the problem.  She also made sure I was using both of the little white plastic bits that go around the thread spool and the netting.  (If you need pictures of what I'm talking about, let me know.  I'm happy to do so!)

Also, have you cleaned out underneath the plate and bobbin area?

What brand of embroidery thread are you using?  I also had the problem with the brand that came with the machine.

If none of that fixes it, where'd you buy it?  You could call and ask them - it may be time for maintenance, or if you have a Cindy at your store (who is awesome, btw) she might have you bring it in to see if she can fix it.  She didn't charge me for the visit at all.  Smiley  (Then again, she didn't do anything ... but still.)
THIS ROCKS   Logged
Serephita
« Reply #2 on: November 04, 2012 11:33:01 AM »

Hi! And thank you for the welcome! I actually did take apart the bobbin portion of the machine, and discovered some thread in the upper tension disks that was throwing off the tension for the entire machine. That seems to have fixed the issue, although I was prepared to take it in to the local Viking Gallery (I bought mine at a JoAnns Gallery as well!) if I had to. I find that I generally have better luck with Robison Anton threads, and tend to lean towards those rather than the ones that came with the machine. Thank you for your help though! I'm glad to know I'm not the only one who has this problem with the machine and with the embroidery thread that came with it!
THIS ROCKS   Logged
kaz814
Cooking Moderator
Purses, Bags, Wallets Moderator
Reusing, Recycling, Recrafting Moderator

Tutorial Contributor

Friend of Craftster Friend of Craftster

Offline Offline

Posts: 5733
Joined: 03-Oct-2009


View Profile WWW
« Reply #3 on: November 04, 2012 05:19:28 PM »

I'm so glad you fixed the problem!  Cheesy
THIS ROCKS   Logged
Threads you might like:
Pages: [1] Jump to page:
  Send this topic  |  Print  |  Bookmark  
 
Jump to:  



FacebookTwitterPinterest
only results with images
include swap threads
advanced search



your ad could be here!

How-To Videos
VF COLLECTIONS: Martin Grant Spring/Summer 2015 - Paris Fashion Week
VF NEWS: Martin Grant Spring/Summer 2015 - Paris Fashion Week
4 Ways to Wear Distressed Jeans
How to Pull Off Wearing a Turtleneck Like Kim Kardashian
10 Moto Jackets for Under $200
Latest Blog Articles
Handmade Gift Ideas: Hippogriff
Handmade Gift Ideas: Exploding Needle Box
Handmade Gift Ideas: Japanese Shibori Dyeing

Comparison Shopping




Support Craftster
Become a
Friend of Craftster

Buy Craftster Swag
Buy Craft Supplies
Comparison Shopping

Craftster heartily thanks the following peeps...
Moderators

Follow Craftster...






Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC
SimplePortal 2.3.5 © 2008-2012, SimplePortal
Valid XHTML 1.0! Valid CSS!

Copyright ©2003-2014, Craftster.org an Internet Brands company.