A Crafts Community For Craft Ideas & DIY Projects - Craftster.org
Help | About | Contact | Press | Advertise | Terms | Site Map
Welcome, Guest.
Please login or register.
Random Tip: Joining an Organized Swap? Please review the rules and info on a regular basis.
Total Members: 296,699
Currently Running With Scissors:
621 Guests and 22 Users
Home Craftster Community Crafting Articles Craft Tutorials My Craftster Crafting Calendar City Guides Craft Shop


Pages: [1]
Jump to page:
  Show Images Only     Send this topic  |  Print  |  Bookmark  
Topic: PLEASE HELP!  (Read 614 times)
Tags for this thread:  Add new tag
Share the love... Pin it Submit to reddit add to Wists
1+
 
gammyk
« on: October 26, 2012 08:27:30 PM »

I've been sewing for many years, but never had an embroidery machine.  I purchased the Viking HClass 600E.  I was so happy and excited to start doing my own embroideries on the things that I make.  Today I spent 8 hours trying to make trick or treat bags for my grandkids.  I am very discouraged right now, when I hit the start button more times than not the machine stops and I have a mess underneath, it seems to be all my top thread.  What am I doing wrong.  What do I do with the tail of the top thread when I start?  Do I hold it taunt or just leave it lie to the side.  Why does it end up in a mess underneath?  Any advise would be greatly appreciated.  I am ready to throw this machine out the window.
« Last Edit: October 27, 2012 09:57:42 AM by gammyk » THIS ROCKS   Logged
kaz814
Cooking Moderator
Purses, Bags, Wallets Moderator
Reusing, Recycling, Recrafting Moderator

Tutorial Contributor

Friend of Craftster Friend of Craftster

Offline Offline

Posts: 5363
Joined: 03-Oct-2009


View Profile WWW
« Reply #1 on: November 03, 2012 06:55:06 PM »

Hi!

Okay, I was getting the mess underneath, too. (I've got a Viking as well.)  It has to do with the making sure that you're getting it threaded properly.  When I was doing it, mine came off one of the parts.  It was the last movable arm thing before the needle - I think it's the thread take-up if google is not lying to me.

Where did you get the machine?  I got mine at Joann's and I called when I was having the above problem and brought it in to the Viking Center to get it looked at by the saleswoman.  (Of course, it worked fine while I was there.)

As for the tail of the top thread, I hold onto it for a few stitches (loosely - I don't tug) and then my machine pauses so I can cut it.  If yours doesn't do that, I would hold onto it for the first 10-15 stitches to make sure it's out of the way and not being pulled under.

Anyway, I hope this helps. GOOD LUCK and tell me if this works.
THIS ROCKS   Logged

Threads you might like:
Pages: [1] Jump to page:
  Send this topic  |  Print  |  Bookmark  
 
Jump to:  



only results with images
include swap threads
advanced search



your ad could be here!

How-To Videos
Terra Elan McVoy on Being Friends With Boys
Jeremy Toombs Performs His Poem "The Alleppey Express"
Finale Book Trailer
Author Bob Woodward Discusses the Economic Crisis
Bob Woodward on America’s Future
Latest Blog Articles
Meatless Monday: Kale and Edamame Salad
@Home This Weekend: Teacup Bird Feeder
Winner of Craft Challenge #100-Pottermouth

Comparison Shopping




Support Craftster
Become a
Friend of Craftster

Buy Craftster Swag
Buy Craft Supplies
Comparison Shopping

Craftster heartily thanks the following peeps...
Moderators

Follow Craftster...






Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC
SimplePortal 2.3.5 © 2008-2012, SimplePortal
Valid XHTML 1.0! Valid CSS!

Copyright ©2003-2014, Craftster.org an Internet Brands company.